Panzer Dragoon Saga Upscaled and Widescreen

Hello first off want to say how much this website has helped me and also just being an overall awesome repository for all things Panzer Dragoon and thanks for that. I wanted to drop in and say I did a long play recent of all 4 CD’s of Saga on the Yabause emulator but I went ahead and upscaled it about 16x and used HexEdit to changed some values to enable a proper aspect ratio 16:9 widescreen. I know it’s not an original hardware but I tried to make the most cleanup version of the game I can after seeing not many good quality stuff on Youtube. Again thanks for the website and just wanted to give a link to my playlist if you wish to add it. Link


Welcome and I’m glad you’ve found the site useful.

How large would all of your videos be in MB/GB? I ask because we have limited storage space, so we have to be selective regarding what we decide to add to the archive.

I compressed them down to 20gb each but I think even a more compressed version will be too much to host but I can if you wish. Well in any case the Youtube link is there for anyone wanting to see. Thanks again!

Yeah, our total webspace is about 20GB so we won’t be able to host them. But it might be worth us linking to YouTube videos such as these somewhere in the archive. I’ll have a think about where we could put them.

I added a link to your videos @computermachina. It’s part of the new Panzer Dragoon Websites article:

The problem with Yabause is with most or all controllers the L and R back buttons don’t work…Meaning it won’t let you set them as inputs for some reason.

Here is another thread on this issue for reference:

I also tried other controllers besides xbox360 and the L and R triggers didn’t work on them either.

Thanks so much for putting it up! Appreciate it allot.

Have you looked into Kronos Yabause? I was using Kronos Yabause v1.6.0 for the recording and the left and right shoulder buttons worked just fine for the fight rotations in Zwei and Original. It seems to have abit more options than regular yabause as well.

Yeah, it seems like the button inputs will work now but I can’t get any of my ISO’s to work/run. Do I have to go into my ISO game files in notepad and change the paths or something? Seems like more trouble than it’s worth…

My ISO path looks like this and is not working. What should I change it to?

FILE “Panzer Dragoon Saga (Disc 1 of 4) (NTSC).BIN” BINARY
TRACK 01 MODE1/2352
INDEX 01 00:00:00
INDEX 00 60:59:23
INDEX 01 61:01:23
INDEX 00 61:09:60
INDEX 01 61:11:60

Okay I got Panzer Dragoon Saga to work. Had to go into my graphics card and set OpenGL rendering GPU to what my graphics card is.

But I can’t get a lot of games to work/boot up. Astal amazingly started up but I couldn’t get NiGHTS into Dreams to start up no matter what path I tried…

Hey yeah to just say what I got going on my setup is basically I have my original cd’s and rip them using ImgBurn which creates a .Bin and .Cue file and I use the .Cue to load up on Yabause. Due to some imports I got I also have 3 Sega Saturn Bios .Bin files (EU,Jap,US) in the root directory in case of conflict. Also got the cart/memory section on the 32mb Backup Ram. Lastly about Nights I remember running into something similar I found this to work: load the game then select File/Load-Eject ISO which should bring you to the Saturn boot menu and from there load the game again it seemed tow ork for me. Hope this helps

Panzer Dragoon and Zwei aren’t working either…

Only thing I can think of is have Enable Bios Emulation unchecked and have a proper .Bin loaded that was probably the last thing I ran into as an issue. Hope you get it running.

Thanks unchecking Enable Bios Emulation worked. Panzer Dragoon and Zwei work now. But no matter what version or what CUE I use, Nights into Dreams refuses to boot!!

Ok so I loaded it up to remember the issue because I believe we encounter the same thing. So these are the steps that I got it to run for me. While Yabause is in windowed mode when I load the .Cue I’ll get the Sega Saturn boot logo, A Sega logo then nothing but black forever. While in that black screen ill select in Yabause File- Eject/Load Iso this will take you to the Saturn Bios menu stating “Disc Tray Open”. While still in that Bios menu again in Yabause select File- Eject/Load Iso and select your .Cue again. Now in the Saturn Bios menu it should select the top left option saying “Start Application” and hit the select button. It should load from there but I did notice a long load time from the sega logo to the Nights main menu so give it a minute or two. Hope this helps.

Thanks that worked. But I found out I don’t have to start the game twice. The first boot up after the Sega logo is a black screen. But if you press start, it goes to the title screen right away!!

@computermachina Have you gotten the L and R to buttons to work on the 3D pad controller input? I’ve only managed to get it to work on the regular game pad…

Unfortunately I do not have that controller

No, what I meant was when you go to set up any controller, you can pick from a drop down list:

Mission Stick
3D Control Pad

I set my controller up for the Pad option input, the only option where the L and R buttons work for me. What I was saying was, when I try to set my pc controller up as the 3D Control Pad, the L and R inputs don’t work. I was just wondering if the 3D control Pad input works for you and you can fully use the L and R buttons on the pc controller you’re using…

I’m in fullscreen but still see a top menu bar. I keep pressing Alt+enter to go in and out of fullscreen but the top menu bar won’t go away. Does anyone know how to get it to go away?