More .cpk problems

Viewing .cpk movies (specifically Panzer Saga’s) used to be a problem until with the help of this board, and’s codec-thing that I was able to view the movies successfully.

Now, something has changed…somehow.

When I boot up cinepak viewer, it reports that it cannot find “SHELL.DLL”.

As always, any insights are helpful. I’ve ran a search of this file on my computer, but (as expected) no useful results turned up.

(Also, if you are somehow wondering about the fmv script, it’s been done for quite some time. However, due to the missing lines, and Lance’s apparently complete version, I assumed he would submit the full version and since withheld my version. If you want mine, I’ll email it ASAP)

I think your edited script would be most welcome; the version in my complete script really wasn’t going to be much better than the one currently on the site (and after it lounged about on my hard drive for three months in a 98% finished state, it seems that I unfortunately managed to delete the script I was editing anyway; I haven’t got around to re-doing it yet).

I’m afraid I can’t offer much help with the .cpk problem though, as my knowledge is hideously lacking in that area. My first move would be to download a fresh copy of the thing, but I expect you’ve tried that already…

I just got your email Lundi. Great work, the formatting is much nicer now. I like the way, you’ve listed what files the text comes from too. This will certainly save Lance a lot of time and effort, too.

As for the CPK problem, all I can suggest is that you try re-downloading it, both from RPGFan, and this site. Hopefully one of the two versions will fix your problem.

Well, I’ve browsed around my files, and found a file of the same name “SHELL.DLL”. I don’t know why it won’t recognize the file, I’ll have to see about that.

I’ve also tried to convert the cinepak files to an .avi extension using a dos program “cpk2avi”, but that won’t load when I use windows (double-clicking on the application icon); the program automatically shuts down. Do I need to use the command prompt to access the application? If so, is there a place where I can learn basic DOS command line structure? I’m near illiterate on how to run applications using DOS.

There is no common method to work with DOS command lines.

You just use program.exe argument1 argument2 argument3.
Most of the time you get help with program.exe /? or a similar argument.

That’s about it.

There’s also a tutorial in the Programs section of this site that explains how to convert PDS’s movies with the ACPK2AVI Converter.